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DS400.ini
You can control which communications resources on your PC you want to let
DirectSOFT4 use by editing the entries in the ds400.ini file (Directsoft version 3 is
DS300.ini, Directsoft version 2 is DS200.ini, Directsoft version 1 is Dirctsft.ini)
Directsoft, DSLaunch, DSData, LookoutDirect, and/or Directlogic Plus must be restarted
for changes to take effect.
Communications Resources
To access the ds400.ini file:
From Windows Desktop: Start → Run, type in "ds400.ini" press the <OK> button. This
will pull it up into the Notepad text editor.
There are two sections in the ds400.ini file regarding communications resources (the
entries may not appear in this order.) Changes to the DS400.ini file will only affect the
version of Directsoft, LookoutDirect, DSData, or DirectLogic Plus that uses that version
of the Com driver.
[devasync.dll]
COM1Enable=1
COM2Enable=1
COM3Enable=0
COM4Enable=0
ModemEnable=1
COM5Enable=0
COM6Enable=0
COM7Enable=0
COM8Enable=0
[devether.dll]
EthernetEnable=1
To disable a resource, type a zero "0".
To enable a resource, type a one "1".
Note: If values are changed you must save the file ds400.ini, and restart DirectSoft.
Changing the default project directory that DirectSoft uses.
Close DirectSoft (if you have it open).
From Windows desktop, Start → Run...
Type in "ds400.ini" (if you have DirectSoft v4.0), or "ds300.ini" (if you have DirectSoft
v3.0).
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Press <OK> button. This should open up a text editor (usually Notepad) showing the
contents of this file.
Find the heading [PATHS]. Under this heading you will see a "PATH" line, looks
something like:
PROJECT PATH=C:\Directsoft4\Projects\
Edit this path to point to one of your own choosing.
Save the file and exit.
Restart DirectSoft to make the changes effective.
Now when you use "Save" or "Save As..." or "Open," etc., the default directory will be
the one you entered.
General Settings
[SETUP]
UseLargeBtns=1 (for new style, 0 for old style)
AUTOCONNECTMIB=1 (for no auto detect, 0 for auto detect)
[Comm Server]
Autosense=0 (for automatically sensing which links are connected)
The Auto settings will not work until there is at least one valid link defined.
Enabling the Communications dump
[devasync.dll]
Dump=1
Use C:\Directsoft4\Bin\DBWin32.exe to view. Or you can also launch "DBWin32
Logger" from the DSLaunch window -- or from the Windows START Menu, under the
AutomationDirect Tools folder, or under the DirectSOFT 4 \ DirectSOFT32 Data Server
Tools folder.

Directsoft Startup
Using the resources enabled in the ds400.ini file, the DirectSoft Com Server tries to find
PLCs.
If it finds some, it creates DirectSoft links to them.
If it finds none, then it comes up without creating links.
If it attempts to use a resource that is not physically present on your PC then one of the
following happens:
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Communications Errors
General Errors
“COM Port Not Present or in Use by other application”
This means DirectSoft can't gain access to the COM port because something else is using
it. Try disabling all com resources. Check to see if anything else is using the COM port
(USB, mouse, etc.)

RSLogix
For Windows 2000 Pro and XP go to Start → Control Panel → Administrative
Tools → Component Services → Service (Local), (Windows NT – Start →
Control Panel → Devices) and scroll down to the AB software. You will likely find
RSLINX AB PIC Driver, Started and Automatic. Change the device setup to
RSLINX AB PIC Driver, Manual. Restart the computer.

PDA Software (Activesync or Hot Sync)
This software will usually be found in the taskbar by the clock.

GPS Software
This software will usually be found in the taskbar by the clock.

Digital Camera Software
This software will usually be found in the taskbar by the clock.

IR Drivers
This driver is usually found in the Start → Control Panel → System → Device
Manager under Ports – COM & LPT or by itself under its own IR Devices heading.
It will attach itself to a COM port. Disable it to allow the COM port to function
normally.

USB-to-Serial Adapter
If you are using a USB-to-Serial converter or a USB Port Replicator, its driver may
not act like a regular COM port. (DirectSoft "thinks" it is talking to a regular COM
port). If this is the case, there is no immediate fix. DirectSOFT is periodically
updated in an attempt to compensate for these kinds of driver problems. If you are
using a USB-to-Serial converter, sometimes it is very important that you load the
driver first, before connecting the device itself. In some cases, if this is done in the
wrong order it takes special steps to fix the problem. See the website of the
manufacturer of your converter for details.
Always make sure you are using the latest build version of DirectSoft possible for
the version you are using.
USB Adapter Compatibility with Directsoft
Automation Direct USB-RS232 p/n USB-RS232 (Windows 98, Windows ME,
Windows 2000, Windows XP).
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Belkin F5U103 USB-to-Serial adapter (Windows 98, Windows ME, Windows NT,
Windows 2000, Windows XP).
Belkin F5U105 USB-to-Serial adapter (customer using and it worked).
Belkin F5U109 PDA adapter (Windows 98, Windows ME, Windows NT, Windows
2000, Windows XP).
Belkin F5U409-CU (works but incompatible with Toshiba 5005 laptop).
Keyspan USA-19QW (at least DirectSoft v4.0 Build 16 or DirectSoft v3.0 Build 80
required; Windows XP).
Digi AccelePort USB 2 two-port adapter (Windows 98, Windows ME).
Xircom PGSDB9 USB-to-Serial adapter (Windows 98, Windows ME).
Prolific (customer using on Windows XP and it worked).
Targus (DOES NOT WORK!)
Quatech (DOES NOT WORK!)

Grounding Issues
RS-232 is a ground-referenced signal. This means that if the plc and pc are not at
the same ground-reference potential then the signal will be degraded, sometimes to
the point of no communications. Try unplugging the laptop from the wall or
plugging the pc into the same voltage source as the plc.

Cable
A bad cable will also cause this problem. Make sure the cable is good by checking
against the following pin out diagrams.
http://support.automationdirect.com/docs/commcables.pdf

DCU/DCM switch settings
DCU/DCM modules only understand DirectNet protocol. The Diagnostic, Power,
and possibly the Run lights should be lit. For a D3-232-DCU the Toggle switch
should be in the online position, on DIP switch block one the only switches that
should possibly be on are #6, 3, 2, and 1. DIP switch block two is used to set the
station ID. This same address must also be used when settingup the link in
Directsoft. Zero is not a valid address. For a D3-422-DCU the same switch
settings apply, but the customer must be using a RS-422 converter such as FAUNICON with the FA-CABKIT and the S2-25P-CVR adapter (Included with the
FA-UNICON). It also helps to power up the PLC and DCU at the same time.

“Required Features not installed”
This means that support for the particular plc model is not available. A reduced feature
set of Directsoft was installed or an upgrade was installed over PC-PGM-205, PC-PGM105, 405 OEM, etc... To check what CPU versions that Directsoft has available start
Directsoft and go to Help → About and look in the white box under “Support Installed
For.”
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“PLC ID does not match”
This is usually a sign of a corrupted scratchpad in the plc. This can be sometimes fixed
with a handheld programmer, but this is not always the case.

“Comm Error reading Program from PLC “
This error means that DirectSoft received an incorrect response from the PLC, so the
physical connection is probably OK.
Usual causes include noise, grounding issues, or possibly the voltage selection jumper on
the plc (if so equipped.)
Increase the link's Retries and Timeout values especially if using a modem link.
If using a modem link, make sure that both the Compression and Error Correction are
turned off.

“Error connecting to PLC – EXT Error”
This means DirectSoft found the resource on your PC OK, but it had trouble connecting
to the PLC. Check cabling or other physical things outside the PC.
If you are using a USB-to-Serial converter, it could be there is an incompatibility
between your PC and the converter. (E.g., we know of an incompatibility between the
Belkin F5U409-CU converter and the Toshiba 5005 laptop).
Make sure you are not running two copies of the Directsoft Com Server (Directsoft,
DSData, LookoutDirect, and DirectLogic Plus) simultaneously like v3.0 and v4.0. If you
do install two versions, this is OK as long as they are in different folders and are not
running at the same time.
We have found that RSLogix (Allen-Bradley) software interferes with the PC's
communications over serial ports (e.g. COM1.) See the RSLogix topic found under
Communications → General →Com Port not present or in use by other application.
Other causes include noise, grounding issues, or possibly the voltage selection jumper on
the plc (if so equipped.)

“Knowledge base mismatch. Cannot connect to plc.”
The most common cause of this error is trying to connect to a plc cpu that is different
than what the current program is written for. E.g. a 340 program connecting to a 350
cpu, a 250 program connecting to a 450 cpu, etc…
TI335 when using an Automation Direct DCU is seen as a "Stage CPU.”
Power up the TI335 in Program Mode.
Make sure dipswitch #6 is set to ON.
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Check Hex/ASCII mode setting in the link.
A DCU is not necessary; you can connect directly with a cable (D3-DSCBL-1.)
PLC Password prompt, the mouse cursor remains an hourglass and OK button cannot be
clicked.
This is a known bug in DirectSoft. This was fixed in DirectSoft v3.0c Build 80 and v4.0
Build 18, so upgrading to at least these builds is advised. A work-around is simply to
press the <ENTER> key on the keyboard.
“Comm Error Locking/Unlocking PLC”
This is caused by unplugging the cable or otherwise loosing communications before
disconnecting with Directsoft or exiting from Directsoft.
Flashing Run light on PLC CPU
This is caused by the plc being in firmware update mode. The only solution for this is to
get the appropriate firmware update tool and corresponding firmware for the CPU and
updating the firmware.

Ethernet Specific
H2-ECOM modules cannot be placed in slot 0 (the slot next to the CPU in a 205 rack.)
This is the case with most intelligent modules as they conflict with the hardware
interrupts that are present in this particular slot.
ECOM modules cannot be placed in expansion or remote bases.
ECOM is visible in NetEdit and can be pinged, but cannot establish a link in DirectSoft
to it no matter how large the timeout and retry values are.
The command "ping" just communicates to the Ethernet side of the ECOM. However,
when you are setting up a link, you must not only communicate to the Ethernet side of the
ECOM, but also it must communicate across the backplane to the PLC itself. Thus, just
because a "ping" works, or you can see it in NetEdit does not mean you can establish a
link to the PLC.
If you are using IP addressing the PC from which you are trying to establish the link must
have a static IP address. If, instead, the PC has a DHCP-assigned IP address, then the
ECOM will not be able to link to it. The reason is that DirectSoft looks in the registry of
the PC to get the static IP address. If the PC has a DHCP-assigned IP address, then this
field is blank. This can create the symptoms of being able to ping the ECOM yet not
being able to establish a link.
If using an H4-ECOM, check for bent pins on the ECOM, or the PLC, or the slots they
are plugged in to. This is a fairly common problem due to the manner in which modules
of this family are installed.
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If using an H0 or H2-ECOM, bent pins have never been a problem. However, since the
problem is pointing to backplane communications, try connecting to the PLC serially,
create a link, and then use DirectSoft to check if the ECOM itself is logging itself into the
I/O configuration (PLC → Configure I/O). In this dialog, the ECOM should show up as
either "ECOM" or "DCM.” f it is "Empty" or “ABNL” then something is probably
wrong with the slot or the ECOM itself. On the H4-ECOM this could be bent pins on
one of the modules or the CPU.
If the ping response time is greater than 25ms then you will need to increase the timeout
setting in the link setup.
One other reason for being able to ping an ECOM but not being able to establish
communications is that there is a device or software blocking the port that the ECOM
uses for communications. A router, gateway, or software such as ZoneAlarm or other
firewall software can do this. Usually the fix is to allow port 7070 (hex) to pass through
the device.

PLC Type shows as “????”
Check for a bent pins on the H4-ECOM, the slot it is plugged into, the DL450 or the slot
it is plugged into. If DirectSoft or NetEdit is an older version, upgrade to the newest
version. Also check the firmware versions of the PLC and ECOM module.
Speeding up data throughput of an ECOM
Give the ECOM an isolated network if possible, as network traffic can effect data
throughput.
ECOM’s do at least 1 com cycle of approximately 128 bytes per PLC scan, but in faster
CPUs (e.g. DL260, DL05, DL06) it can do as many as 3. So using a faster PLC CPU will
help.
Since the ECOM com cycle is PLC scan dependent, then anything you can do to make
the PLC scan faster will help.
Make sure no other applications or devices are talking to the same PLC via the same
ECOM or serial port (e.g. like having DS Programming doing status while DS Data is
running or PLC doing/responding to RX/WX from other PLC). There is only so much
bandwidth between the serial port/ECOM and the CPU itself.

“Transport Protocol Error”
This means you are using Ethernet as a link and it timed out.
Make sure you have only one Ethernet NIC (Network Interface Card) installed in the PC.
If you have two NICs, make sure one has IPX only. If you have IPX installed on more
than one NIC or you have both NICs tied to the same network, you create what is known
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as the “rabbit-hole” problem. The request goes out one card and comes back in on the
other card, or in some cases comes back twice, once on each card.
Disable the WAN network driver:
(1) Start → Control Panel
(2) Double-click Network icon
(3) Usually has 2 things listed: Local area connection & Local area connection2
(4) Will see Device Names like Intel 8255x x-based Ethernet Adapter & WAN network
driver
(5) Right-click on "WAN network driver" and disable it.
This could be caused by network traffic, or PLC sluggishness. Under the link's
Advanced Settings (Link Editor, Port Tab), try increasing the Timeout and Retry values.
Try going to a Command prompt (Start → Programs → Accessories → Command
Prompt) and pinging the ECOM's IP address (Ping xxx.xxx.xxx.xxx).
If Ping works, note the response times. In the link's Advanced Settings (Link Editor, Port
Tab), increase the Timeout value to at least 2 or 3 times that response value.
1394 (Firewire)
IPX protocol can also be installed under 1394 devices otherwise known as Firewire.
Uninstall this protocol under this device.

“Error opening connection to Ethernet Device”
This is usually caused by having two NICs. Make sure that one has IPX only, and the
other has TCP/IP only.
1394 (Firewire)
IPX protocol can also be installed under 1394 devices otherwise known as Firewire.
Uninstall this protocol under this device.

Modems
See the Technical and Application Notes section of the Technical Support Homepage.
http://support.automationdirect.com/technotes.html
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“CSMAIN.EXE error”
This means that the DirectSoft Com Server has accessed a resource on your PC that has a
conflict or does not exist.
Try disabling all com resources. Make sure TCP/IP and IPX protocols are loaded.
If using v4.0 Build 16 or earlier, or v3.0 Build 71 or earlier, you may need to:
Upgrade to later version and make sure IPX protocol is loaded for the NIC you are using.
1394 (Firewire)
IPX protocol can also be installed under 1394 devices otherwise known as Firewire.
Uninstall this protocol under this device.
Deleting an unused link in DS Launch causes CSMAIN.EXE error
This is probably caused by a corrupt COMMSERV.RST file. This file stores all the
links. Unfortunately, there is no way to repair this file. Therefore the only solution is the
delete it and re-create all your links again. The file is stored in the c:\directsoft4\bin
folder.
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Printing
Update to the newest version of Directsoft. If your ladder displays correctly in Print
Preview, but does not print correctly then you should update your printer driver to the
newest version.
Sometimes deleting the C:\Directsoft4\Program\Bin\Printserv.rst or the
C:\Directsoft4\Program\Bin\program.opt will fix a problem with printing Directsoft files.

No lines are printed
Go to View → Options → Ladder → Misc. Options, 3d may be unchecked or View →
Color → Setup → Token, color may be set to white.
Network Printers
There is a known bug in earlier versions of Directsoft. Upgrade to at least v3.0c Build 80
or v4.0 Build 18.
Print Preview causes "DSP4x.exe" error and "Unable to save workspace. Disk is write
protected or file is read-only!" error.
This is caused by the project files (mainly the .prn and .wsp files) being write-protected.
If you copied the project from another computer, a write-protected disk or possibly a CDROM this can occur.
Close DirectSoft.
Use Windows Explorer and browse to the location of your project.
Click on the first file of the project.
Hold the <Shift> key down and click on the last file of the project. (This will select the
full range of your project files.)
Right-mouse click on the group and select Properties.
Under Attributes, uncheck the Read-Only box.
Click Apply, or OK button.
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Editing Programs
Most Directsoft projects can be transferred to a different plc model with minimal editing,
however programs written for a D3-330 and/or a D3-340 are radically different and
cannot be transferred to any other CPU model without a complete rewrite.
Directsoft is not opening links with ladder view shown or not connecting properly after
double-clicking link
Delete C:\Directsoft4\program\bin\program.opt.

Messages in DirectSoft show up in German
You have Siemens Step7 software installed on your PC. Rename the mfc42loc.dll file
located in the Windows folder to mfc42loc.old and reboot.
Selecting PLC → Tools inside DirectSoft causes my PC to lock up.
We have found this to happen in versions earlier than v4.0 Build 18, when you have
installed CTRIO Workbench and/or ERM Workbench under a different folder other than
from C:\HAPTools.
Uninstall Workbench (CTRIO & ERM) from Start → Programs → AutomationDirect
Tools → Uninstall.
To reinstall, insert DirectSoft Installation CD into drive.
Use Windows Explorer to browse out to CD drive (e.g. D:\Tools).
To install CTRIO Workbench, open CTRIOwb folder and double-click SetupCTR.exe.
To install ERM Workbench, open ERMwb folder and double-click SetupERM.exe.
For each install use the default C:\HAPTools installation folder.
Note: The workbench tools will not install on the Windows 95 operating system.
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File Operations
Saving or opening a project gets an error. "Couldn't open new database. Reopened
failed.” But the program will still come up
Check the Projects Path in the ds400.ini file and make sure it is pointing to a folder that
exists and that you have access to.
DirectSoft File Extensions
CSV - Comma separated variable
CWB - Counter I/O configuration
DTA - Data view
DV - DV1000 setup
ERM - Ethernet remote master config
ESD - Element documentation (nickname, wiring info, description)
ESX - Index for element documentation
INF - Project information
LCD - Ladder comment data
LCX - Ladder comment index
LDA - Maps rung comments to rung #'s
LDO - Online only, maps rung comments to rung #'s (temporary until saved offline to
LDA - file)
PID - PID documentation
PRJ - Ladder program
PRT - Print layout config
RD - 305 R-memory data
RF - 305 R-memory data editor format
SCD - Stage comments
SCX - Index for stage comments
TLS - PLC parameters, I/O configuration, pause bits
TXT - Text file
VD - V-memory data
VF - V-memory editor format
WSP - DirectSoft window layout

Read Only Projects
DirectSoft needs to open up the files as read/write. If you have copied the files from a
CD, you must go into Windows Explorer, Right Click on the project files, Select
Properties, and uncheck the Read Only attribute.
"DirectSoft recognizes the document <filename> but features or support level is not
installed."
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This error means you are trying to read a project file that was written for a PLC that is not
supported in your version. For example, if someone created a project for a DL260 in
v4.0 and you tried to use v2.4 to read the project, you would get this error (See the table
below.)
This could also occur if your version of DirectSoft is a feature-restricted version, e.g. PCPGM-105, PC-PGM-205, PC-OEM-405, etc…
Another possibility is that the project is corrupted and unreadable.

DirectSoft Version
v1.12i

v2.0

v2.1

v2.2

v2.3

v2.3a

v2.4

v2.4a

v3.0

v4.0

DL05

-

-

-

-

-

-

X

X

X

X

DL06

-

-

-

-

-

-

-

-

-

X

DL130

-

X

X

X

X

X

X

X

X

X

DL230

X

X

X

X

X

X

X

X

X

X

DL240

X

X

X

X

X

X

X

X

X

X

DL250

-

-

X

X

X

X

X

X

X

X

DL2501

-

-

*

*

*

*

*

*

*

X

DL260

-

-

-

-

-

-

-

-

-

X

TI325
Direct
Logic DL330
CPUs DL330P

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

TI330S

X

X

X

X

X

X

X

X

X

X

TI335

X

X

X

X

X

X

X

X

X

X

DL340

X

X

X

X

X

X

X

X

X

X

DL350

-

-

-

X

X

X

X

X

X

X

TI425

X

X

X

X

X

X

X

X

X

X

DL430

X

X

X

X

X

X

X

X

X

X

TI435

X

X

X

X

X

X

X

X

X

X

DL440

X

X

X

X

X

X

X

X

X

X

DL450

-

X

X

X

X

X

X

X

X

X

* Partially compatible. The restriction is that the 250-1 local expansion I/O cannot be seen in DirectSoft

Importing a GE LogicMaster Series One program (LAD) file causes error "PLC type is
not supported by any installed knowledge base," or "Unknown file format unable to
import program."
This error means that the ladder program you are trying to import is not a Series One
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Plus CPU (i.e. CPU 105, 106). DirectSoft does not support Series One CPUs, but only
Series One Plus. However, there are two possible causes of this error:
Attempting to import a Series One Plus program, but the DirectSoft is v3.0 Build 58.
This is a known bug in this Build, please upgrade to the newest version.
Attempting to import a Series One program (not supported) instead of a Series One Plus.
However, there still may be a solution. Open the ladder program with the GE
LogicMaster Programming software, change the CPU type to 105 or 106, and resave it.
Since the main (if not the only) difference between the Series One (unsupported) and
Series One Plus (supported) CPUs is the size of the ladder memory, then this will not
alter the program. After resaving it as a 105 or 106 program, then try the Import function
again.
After upgrading from v3.0 to v4.0, is it OK to delete the v3.0 Projects folder?
Yes, but it is important to insure that you have copied your old v3.0 projects (that you
want to keep) to your v4.0 projects folder. This can be done manually if need be.
However, the upgrade process will ask you if you want to do this, and it will do it for
you. It simply does a blind copy of the old v3.0 projects folder to the v4.0 projects
folder. Thus, no files are lost (e.g. documentation.)
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Documentation Errors
Documentation files (comments, etc.) are huge and actually filling up hard drive on PC,
when opening a project, get "DSP4x.EXE Application Error..." and then shuts down, or
getting unpredictable results (e.g. DirectSoft locks up on Export).
Note: Do not use project files across network connections. All project files should reside
on the local hard drive to prevent documentation losses.
There are known problems that can occur when documentation files are corrupted. When
corruption has occurred, it can cause quite a variety of unpredictable symptoms.
Corruption can happen over time due to system/software crashes, power loss, etc. To
facilitate recovery, It is strongly recommended that you utilize v4.0's Backup Project
feature to help minimize any rework. In times past, some of these documentation
corruptions have caused DirectSoft to crash. Crashing behavior in all known cases to
date has been remedied in later Builds of DirectSoft. Therefore, upgrade to the latest
version.
If the documentation is corrupt, sometimes it can be salvaged. There are three file critical
to documentation:
ESX - This file is the database Index for the Element Documentation.
LCX - This file is the database Index for the Ladder Comments.
SCX - This file is the database Index for the Stage Comments.
If these files do not exist, do not worry, DirectSoft will create them, building backward
from the documentation files themselves:
ESD - This file is the database for Element Documentation.
LCD - This file is the database for Ladder Comments.
LDA - Maps Ladder Comments to Rung Numbers.
SCD - This file is the database for Stage Comments.
First, backup the project (if possible). Alternatively, print out the documentation. In
DirectSoft v4.0, there is a new Backup feature that allows you to create backups of your
projects that are time stamped.
ELEMENT DOCUMENTATION ERRORS
Try Deleting the ESX file.
Open DirectSoft and pull up the project.
Export the Documentation to TXT or CSV file.
Edit the TXT or CSV file and correct any mistakes.
Save the TXT or CSV file.

15

APPLICATION NOTE
THIS INFORMATION PROVIDED BY AUTOMATIONDIRECT.COM TECHNICAL
SUPPORT IS PROVIDED "AS IS" WITHOUT A GUARANTEE OF ANY KIND.
These documents are provided by our technical support department to assist others. We do
not guarantee that the data is suitable for your particular application, nor do we assume any
responsibility for them in your application.

Import the documentation from the new TXT or CSV file, choosing the “Delete Existing”
option.
Save the new project.
NOTE: If this does not work, you may have to repeat it, deleting not only the ESX file
again, but the also deleting the ESD file between Step 3 and Step 4 as well.
LADDERS COMMENT ERRORS
NOTE: If Ladders Comments are corrupted in DirectSoft v3.0, there is no solution! To
prevent the loss of Ladders Documentation in DirectSoft v3.0 you should print it out
often.
Delete the LCX file.
Open DirectSoft and pull up the project.
Export the Program to TXT or CSV file, choosing the “All” option.
Edit the TXT or CSV file and correct any mistakes.
Save the TXT or CSV file.
Import the Program from the new TXT or CSV file, choosing the “Delete Existing”
option.
Save the new project.
NOTE: If this does not work, you may have to repeat it, deleting not just the LCX file
again, but also deleting the LDA, LCD and LDO files between Step 3 and Step 4 as well.
STAGE COMMENT ERRORS
NOTE: If Stage Comments are corrupted in DirectSoft v3.0, there is no solution! To
prevent the loss of Ladders Documentation in DirectSoft v3.0 you should print it out
often.
Delete the SCX file.
Open DirectSoft and pull up the project.
Export the Program to TXT or CSV file, choosing the “All” option.
Edit the TXT or CSV file and correct any mistakes.
Save the TXT or CSV file.
Import the Program from the new TXT or CSV file, choosing the “Delete Existing”
option.
Save the new project.
NOTE: If this does not work, you may have to repeat it, deleting not only the SCX file
again, but also the SCD file between Step 3 and Step 4 as well.
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Operating System Specific Problems
Using Windows 2000, creating Data Views to be saved to my server (e.g. mapped drive
K:\), reopening it, making a change, and saving it again, causes "Access to
K:\<pathname> was denied" error.
This is a known problem with MFC/Windows 2000. This means there is a bug with
MFC (Microsoft Foundation Classes) Windows 2000. MFC is a large library of C++
classes developed by Microsoft. For Windows-based applications written in C++, MFC
provides an enormous head start. One of the hardest parts of developing C++ programs
(like DirectSoft) is designing a logical hierarchy of classes. With MFC, this work has
already been done. MFC is bundled with the C++ compiler used to write DirectSoft.
Thus, this "toolkit" though extremely useful, is not perfect. In this case, the problem is
with this "toolkit" and not with DirectSoft.
To work around Instead of using "Save" . . . use "Save as..."
Installing DirectSoft on Windows NT causes "Ctl3d32.dll which is not the correct
version. This version of ctl3d32.dll is designed only for Win32s or Windows 95
systems."
If you are installing DirectSoft on Windows 95 or WinNT, the DirectSoft install engine
puts this version of the ctl3d32.dll file on your system. This is fine if you actually have
Windows 95 machine. However, if you have a WinNT machine, this causes this
problem. This has been corrected but has not been released yet (as of 02/04/03). The fix
is that DirectSoft install engine does not install this file at all. This will be included in a
later Build (>Build 18). To fix this problem you have to replace the incorrect ctl3d32.dll
with the correct one. There are two versions of the file:
ctl3d32.dll 26 KB 5/18/1997 8:54am (Windows 95 version)
ctl3d32.dll 44 KB 5/11/1998 8:01pm (Windows 98 version)
The file is located in your Windows\System folder. Whichever one you have there is the
wrong one. An internet search on this filename should help you find the correct version
to download.
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Install/Upgrade Problems
Always install products while signed onto the machine as the administrator or as
someone with administrator rights. Also, disable any anti-virus software that may be
running.
Installing causes an error with the gpid-vdd.dll file.
This seems to be a Windows 2000 system problem. Make sure your Windows 2000 has
the latest updates. A simple work-around is to just press the Ignore button and DirectSoft
will install properly.
Installing DirectSoft on Windows 2000 or XP causes error "Can't run 16-bit program.
Can't find file c:\docume~1\admin\local settings\temp\pft1~tmp\progrun\setup.exe or one
of its components. Check to insure the path and filename and that all required libraries
are available."
First, if there is an <Ignore> button, try that first. If that doesn't work, notice in the
"Can't find file" message, the "Documents and Settings" path was shortened to
"docume~1" but the "local settings" folder name is NOT shortened to "local ~1.” This is
why it does not work. This is evidently a bug in Windows "NT-style" PCs (Windows
2000), where you have to log in.
Create a temporary folder (e.g. C:\temp)
Right-mouse on My Computer.
Select Properties.
Select Advanced tab.
Press Environment Variables button.
Write down the TEMP and TMP variables' pathnames (if you intend on restoring them
later).
Select TEMP variable from the top list.
Press Edit button.
Change pathname to something very simple (e.g. C:\temp)
Select TMP variable from the top list.
Press Edit button.
Change pathname to something very simple (e.g. C:\temp)
Install DirectSoft.
Restore the TEMP and TMP variable settings if you want to.
My original DirectSoft was PC-PGM-105. Will installing the v4.0 Upgrade gain me the
ability to program the new DL06?
No. The PC-PGM-105 allows you to only program the DL05 and the DL105, and
upgrading to v4.0 will not buy you the ability to program a new DL06. To get DL06
programmability you must purchase at least the PC-PGM-BRICK package.
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Installing DirectSoft on a Windows 98 or Windows 95 PC.
A wide variety of problems with installing DirectSoft on Windows 95, Windows 98 and
Windows Me PCs can be solved by installing in Safe Mode. Safe mode can be accessed
by pressing the F5 or F8 keys during boot up.
Installing DirectSoft on Windows 2000 or Windows XP.
Make sure you are logged on as Administrator.
Installing a regular DirectSoft package over top of the Demo version.
No. It is best to uninstall the Demo version before installing the regular packages of
DirectSoft.
Installing DirectSoft on Windows 95 PCs.
Directsoft itself will work, however we cannot support this configuration. Please
remember that the CTRIO Workbench and ERM Workbench software that installs with
Directsoft will not work on Windows 95 PCs.

19

Directsoft Help
"Cannot find the Progrun.hlp file. Do you want to try to find this file yourself?"
This is a known bug in DirectSoft v4.0. This problem has been fixed and it will be in subsequent
releases greater than Build 18. As far as we know, it only occurs in the following manner:
Click the Help button.
Click the Contents button.
Select "Document a project."
Select "Assign Nicknames."
Select "Export/Import Adding unassigned nicknames to element documentation."
The work around is to access this exact same help in this manner:
Click the Help button.
Click the Index button.
Type "Import Documentation."
Click the Display button.
Select "Import/Export Adding unassigned nicknames to element documentation."

Technical
Assistance: If you have questions regarding this Application Note, please contact us at
770-844-4200 for further assistance.

