Troubleshooting
Guide: WinPLC,
RuntimePC & Windows NT 4.0
Symptoms:
You are unable to find your Think & Do WinPLC using "Find CE Runtime..." option
from ProjectBinder or ESP.
Possible
Cause(s):
- Bad or wrong Ethernet
cable.
- The Subnet Mask of the
WinPLC and on your PC does not match.
- Conflicting IP Address.
- The DHCP Server is unavailable
or your PC is not connected to the network.
Resolution:
- If the Link LED is off
on the WinPLC you have a bad or wrong Ethernet cable, which needs to be replaced.
- Correct the Subnet Mask
or assign a static IP address and Subnet Mask to your PC.
- For your PC: Select
Settings ... Control Panel from the Start Menu. Double-click on the Network
Icon. Select the Protocols tab and double-click TCP\IP Protocol.
- The default settings
for the WinPLC are: IP address - 10.0.1.100 and the Subnet Mask - 255.0.0.0.
Your PC must match the Subnet Mask of the WinPLC. If it doesn't, change
your PC's IP address to 10.0.0.1 and the Subnet Mask to 255.0.0.0 or if
you have changed the IP address and Subnet Mask of the WinPLC, change
your PC to an available IP address and the same Subnet mask. This will
allow you to see the WinPLC and change its configuration.
- For the Think & Do
WinPLC: From ProjectBinder select "Find CE Runtime..." from the drop down
list. From the Find\Configure CE Runtime dialog, click the Reset Using
IPX button. Enter the MAC address of you Think & Do WinPLC. This can be
found on the inside label of the Think & Do WinPLC (e.g. 00.E0.62.80.00.64).
Recycle the power on the Think & Do WinPLC and you will see a dialog appear
showing the Name and Description of the Think & Do WinPLC. Click the IP
Address tab and reset the IP Address and Subnet Mask to match your PC.
Click the OK button and recycle the power on the Think & Do WinPLC. Press
the Re-scan button and your Think & Do WinPLC will appear in the list.
Symptoms:
You can find your Think & Do WinPLC, using "Find CE Runtime…" option from ProjectBinder,
but you are unable to download to the WinPLC or you are unable to scan the WinPLC
using IOView.
Possible
Cause(s):
- LMHOSTS File lookup is
disabled.
- "Enable IP Forwarding"
is disabled.
- You do not have administrator
privileges on Windows NT.
Resolution:
- The LMHOSTS lookup option
must be enabled in the TCP\IP Protocol configuration. Select Settings ...
Control Panel from the Start Menu. Double-click on the Network Icon. . Select
the Protocols tab and double-click TCP\IP Protocol. Select the WINS Address
tab and place a check in the Checkbox next to "Enable LMHOSTS Lookup". Select
the OK button and you will have to reboot your computer in order for the changes
to take affect.
- If the system has two
or more Ethernet cards, "Enable IP Forwarding" needs to be enabled. This is
down in the TCP/IP Properties on the routing tab.
- Log On to Windows NT
as the administrator or a user with administrator privileges.
Symptoms:
When you start to download
and run your project, there is a long pause, about 3-5 seconds, before you see
the files being download. Or it takes approximately 5-10 seconds before ESP
connects to the WinPLC.
Possible Cause(s):
Your PC may normally be connected
to a network where a DNS Server exists and your PC relies on the DNS Sever for
HOSTS name resolution. When you are not connected to the network, your computer
waits for a response from the DNS Server in which it will not receive a reply.
This time period can last anywhere between 6-12 seconds.
Resolution:
If you are not connected
to your network at the time you would like to communicate to the WinPLC, you
should remove the DNS Server(s) IP Address from your TCP\IP configuration. Select
Settings ... Control Panel from the Start Menu. Double-click on the Network
Icon. . Select the Protocols tab and double-click TCP\IP Protocol. Select the
DNS tab and look for IP addresses in the "DNS Service Search Order" list. Record
any IP addresses listed, so you may re-enter them later, then remove all IP
addresses in the list. Reboot your computer and download your project again
to verify that this resolves your problem.
Symptoms:
You can use the "Reset Using
IPX" option to find and configure a WinPLC but can not see it when using the
"Find CE Runtime.." option.
Possible Cause(s):
The Default Gateway is not set on the WinPLC.
Resolution:
When using a PC with one
or more Ethernet cards, the WinPLC's Default Gateway needs to be set to the
IP address of the Ethernet card to which it is connected.